XREAでWordPress

そういえば、3連休で、ちょいとたのまれたので、WPを調子こいて導入しました。

XREAサーバに。

これが曲者でした。

セーフモードが何チャラで、PHPをCGIで動かすように、htaccess書きなおさないといけなくて、
いや、別にいけなくはないものの、そうしないと、

●プラグインのUPDATEが自動でできない。

って事態に陥ります。

これに関しては、皆さん陥っているらしく、XREAのヘルプにも回避方法書いてありました。(なら、その設定が必要じゃないようにしてくれればいいのに。。)
ただ、特に理由があるわけじゃないんだけど、そうすることに、抵抗がある。。。のは、そうしちゃったときに生じる、マイナス面が把握できないからかな。

セーフモードとやらにしてるには何か意味があるのだろうから、それを回避しちゃうって言うと、相応して、セキュリティ的な何かに欠陥がとかあったりしそうとか。。。
この辺の事にめっぽう弱いので不安になっちゃうんですよ。

といっても、ダウンロードして入れ替えるのって面倒だし、まだ、プラグインなら手動でもいいとして、WP自体のUPDATEが自動でできないってなんか面倒。
どうしたものか。。。

●テーマの編集ができない。。

これは、権限を変えたら出来るようになったけどね。それもセキュア的な概念でやっていいのかとか微妙に不安。
だから、これも、ローカルで書き変えてUPすることに。
その方がバックアップの取り忘れはなくていいかもですが。


トータルとして、ロリポップってやっぱり素晴らしいね。と思います。

WPをロリポップに入れるときは、こんな苦労なかったもんなー・・・a-04.gif

WPって簡単~って思っていたけど、それよりもロリポップとの相性が良かった事が素晴らしかったのかもしれません。

COMMENTS & TRACKBACKS

  • Comments ( 2 )
  • Trackbacks ( 0 )
  1. By エフコジ

    ロリポップのPHPは常にCGIモード、XREAはモジュールなのよね。

    ・CGIモードは動作が重い、セキュリティ面で安全
    ・モジュールは動作が軽い、共用サーバーだとセキュリティ面にわずかな不安

    セーフモードなのは共用サーバーでモジュールで動かしているからとか、そのあたりが理由だと思う。

  2. By cocoping

    ふむ。。。

    よくわかんないけど、やっちゃって大丈夫ってことかしら?

    テーマの編集は出来るようになるんだけど、プラグインの自動UPDATEはなんか知らないけど、どこまでいってもエラーが出るのよね。
    一つ直ってもまたでます。みたいな。

    もう、だめだめです。へへーぃ♪

    ・・・・・こんなんで本当にすいません。エフコジさんはいい人です(涙。。。

LEAVE A REPLY

*

COMMENT ON FACEBOOK